Universal App in Phone and Tablet Without Icons

Sometimes, when we install Universal App on our smartphone or tablet (NAV 2016 and NAV 2015 – only for tablets), we can notice one issue with missing Icons (Actions, Images,…). This is not something serious, but it can be unpleasantly.

UnAppNoIcons.png

But, it can be solved very easy. The reason of this issue is because your browser has configured Font download option as disabled.

NoFonts

You can solve this changing this property or adding your site as Trusted. To do this, you need to open your Internet Explorer, run your Microsoft Dynamics NAV web client and open Internet Options. Choose Security tab and choose Sites on the Trusted sites option. Add this sites as trusted and this is solved. Second way is to open Custom level and find Downloads section and change Font download to Enabled.

Now, you can run your Universal App again and everything will be fine:

UnAppYesIcons.png

Advertisements

2 thoughts on “Universal App in Phone and Tablet Without Icons

  1. Same thing can happen if you did not use powershell to add the website but created the website instance manually and you did not create the virtual directory within the website to the “secret” resources folder. Then you will have a security issue on c:\programdata\……and the icons will not load!

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s